Blind Gamers

Arch linux problems

hello there!
since I see people are not so interested in this forum anymore, I’m trying to make a topic here that would perhaps draw more technically inclined people around here to answer, kinda like in
now, I’m a native linux user for some years now, however I always used ubuntu, nothing else.
Due to a friend advicing me on trying arch with the mate desktop, I went ahead and downloaded the iso.
Upon boot, I press down arrow and enter to boot into the accessible version of arch. All well and good, I hear espeakup starting and rattling off about modules being ready, entering automatic root loggin and blah…blah…blah.
However, when it arrives to the prompt, it just says root@archiso$ and then…complete silence.
Whatever I do, I can’t make it talk, I’m entering commands and speech doesn’t start again.
Apparently, something is wrong with espeakup, since on shutdown, it prints something along the lines that the unit speech output for espeakup froze or something.
With the limited ocr possibilities under linux, I was able though to kinda capture the shutting down message for that particular job.
a stop job is running for Software speech output for Speakup (IZS / Imin 30s)
Well, the output is kinda garbled I admit, but I can’t do much about that, this is the ocr quality we have under linux. However, even from that snapshot, we see that the job is hanging, in short, espeakup is blocking in some fassion. That number kepped increasing, untill I forcefully shut down the vm.
For reference, I am running this with ubuntu as host, obviously, arch as guest and virtualbox as the virtualisation platform.
O, before I forget, besides the advice of my friend that mate is faster on arch than ubuntu, I also want to run arch because I want to try audiogame manager, it doesn’t work on ubuntu because it requires some dependencies that I DK how to get.

I was able to get it to speak when installing to bare metal. Maybe it is something caused by the virtualization software. I wonder if you couldn’t boot it without speech, then ssh in and set it up like that?

Do you know how to use qemu enough to try it for the vm? You can even start it without graphical enabled, so it just works like a standard console. If you would like, we can set up a time to meet on the Stormux mumble server and I can try to help you in real time.

AGM should work in Ubuntu. I know there are some Ubuntu users on the forum who are using it. Mostly it’s finding the right names for required packages.

1 Like

Agreed, it could be a problem with the virtualization stack. You could set up a means of sshing into the VM and installing Arch that way. That will at least get you a base installation, but it won’t necessarily solve your espeakup problems.


well, one of the laptops I have incounters the same weird problems, but the other doesn’t…hmm…
anyways, I know qemu well enough to set up a vm, plus there’s that grafical tool…how was it called? virtmanager? something like that anyway.
Thing is, when I try to boot it in emulation mode, like when you play one of those ps2 games on software emulation, it works, though it’s kinda slow and weird.
However, whenever I enable hardware acceleration, eg --accel kvm, --use-kvm, etc, the problem happens again.
I tryed jenux as well, even though I don’t particularely like the way that installer was made, however no luck. Worse, it got stuck at the loggin prompt, displaying something about automatic root loggin as with the arch image, however then it broke.
I guess I get this problem only on arch specific distros, debian derivations don’t have this, hmm…
and the stormux what server? what is stormux? what is a what? mumble… server?
plus, is it possible to ssh in an arch iso? how can it be done? since it’d certainly be more productive than what I must do now, with crappy ocr. Do I have to install the ssh server on it, eg pacman -S openssh-server, or is it preinstalled?

You can ssh into a live environment. You will need to install ssh:

# pacman -Sy openssh

You should also create a temporary unprivileged user, so you can ssh in to it, and change to root. I think that ssh to root specifically isn’t permitted. So:

useradd -m -s /bin/bash archie

Of course you can replace archie with whatever name you want, but it’s only temperary. Remember to also set a password for both root and the new user:

# passwd archie

Passwd with no argument will let you set a password for root. Then, start sshd:

# systemctl start sshd

At that point, you can ssh into the system. You can find the ip address of your live environment with

# ip address

mumble is an open source voice chat server. It was originally developed for gaming, and still supports things like overlay, positional audio, etc but it is also used for just talking, meetings, whatever. The latest git versions have stereo support too.

Stormux is my company, which also does the Stormux OS for the Raspberry Pi. It’s based on Arch Linux, and currently is basically just talking Arch for the Raspberry Pi. It is a continuation of the F123Light project which lost funding a couple years ago. Stormux also provides some classes, and most recently, the BPG game which started out as a thank you for my Patrons, but then other people wanted access, so now it’s available from the Stormux website.

I think that covers everything. I have only had one cup of coffee though, so I could possibly have missed something. Anyway, I hope this helps.